Jump to content

Commcial Checkride this week!


Recommended Posts

Good luck (if you haven't done it already.) Let us know how it turns out.

 

Just a side note -- there's a little typo in the topic heading and I actually read it as "comical checkride" Hope it's fun, but not necessarily funny...

 

:D

 

HVG

 

You're right! very "commical" but definitely a typo...you should see me talk and fly at the same time!!

Link to comment
Share on other sites

Welcome to the club! But first things first, you'll be needing one of these....

 

StraitJacket.jpg

 

 

Hey have you got one of those in a 48 Long ??

Link to comment
Share on other sites

Congrats. job well done.

Link to comment
Share on other sites

Greetings everyone. Passed Commercial Checkride today! One of the most fun I have done.

 

Thanks to the DPE and my CFI.. now.. on to CFI

 

Rotorrodent

 

 

(Sorry about the "dual" post. There was some kind of fault in the server yesterday with no response to my entries.)

Link to comment
Share on other sites

Greetings everyone. Passed Commercial Checkride today! One of the most fun I have done.

 

Thanks to the DPE and my CFI.. now.. on to CFI

 

Rotorrodent

 

BTW- wanted to add for the new guys...It was almost a year ago that I first started training. I was the one who posted "can't hover within a square mile". So between work, home etc...it took about 1 year for Commercial...and yes I can now hover within a square block! LOL

Link to comment
Share on other sites

You can delete a post at the bottom left of the post, the box says, "Moderation Options", click it and highlight delete post, then click the "go" button to finish the delete...

 

 

Congrat's Too................ Take care.

Link to comment
Share on other sites

You can delete a post at the bottom left of the post, the box says, "Moderation Options", click it and highlight delete post, then click the "go" button to finish the delete...

 

 

Congrat's Too................ Take care.

 

I would have attempted that but everytime I clicked on "any" kind of link in the forum, the system (server?) would just grind and grind with no results. Whenever I entered anything the system would just hang and so never did know if anything worked or not.

 

Next day when I signed on, everything on the forum was just fine with of course, two topics!

 

Thanks for the reply....nice to know that computers can have LTE!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...